Alves Outage

Minor incident Wester Alves Mast
2025-04-18 19:49 BST · 12 hours, 22 minutes

Updates

Resolved

Power outage resolved

April 19, 2025 · 08:11 BST
Issue

we are currently investigating an outage affecting our Alves fibre and wireless networks. Engineers are looking into the cause and we will provide further updates as soon as information is available.

April 18, 2025 · 19:49 BST

← Back