Weather related issue

Major incident Brown Muir Mast Sunnyside Relay Cul Mor Relay Ark Childcare Relay Glen of Rothes Relay
2023-03-13 09:57 BST · 1 week, 1 day, 22 hours

Updates

Resolved

This was resolved

March 22, 2023 · 07:57 BST
Issue

We have identified an issue at our brownmuir mast affecting a few sites and are working to resolve the problem.

March 13, 2023 · 09:58 BST

← Back