SSE Power Outage

Minor incident Brown Muir Mast Salterhill Relay East Mains Relay Newton Relay
2024-01-24 09:12 BST · 1 day, 23 hours, 39 minutes

Updates

Resolved

Power outage resolved.

January 26, 2024 · 08:52 BST
Issue

We are aware of an SSEN power outage affecting properties between Elgin and Lossiemouth. Services in this area may be at risk until power is restored.

You can follow the power outage on SSEN’s PowerTrack site at https://powertrack.ssen.co.uk/powertrack#NG1049

January 24, 2024 · 09:12 BST

← Back