Power Issue Affecting Our Hythehill Mast Site

Major incident Brown Muir Mast Salterhill Relay Newton Relay
2024-02-14 10:57 BST · 58 minutes

Updates

Resolved

The power issue at Hythehill has been resolved and all systems are fully functional again.

February 14, 2024 · 11:54 BST
Issue

We have a power issue affecting our Salterhill, Muirton and Newton customers. An engineer is on his way to investigate.

February 14, 2024 · 10:57 BST

← Back