Loss of service
      
Minor incident
      
        Brown Muir Mast
        Sunnyside Relay
        Ark Childcare Relay
        Glen of Rothes Relay
    
    
      
2024-09-28 16:51 BST
      
      · 28 minutes
    
  Updates
          Issue
        
        
September 28, 2024 · 16:51 BST
        
      
  Engineers are currently investigating an issue affecting customers in the Gownie/Aberlour, Glen of Rothes and Mosstowie areas of our network.
Issue resolved and all systems restored.
← Back
 WiFi Scotland
            
WiFi Scotland