Openreach Fibre Outage

Minor incident Openreach Fibre
2024-10-20 23:41 BST · 1 day, 15 hours, 3 minutes

Updates

Investigating

It has been confirmed that this outage has been caused by a downed fibre cable due to the high winds. We are awaiting Openreach engineers arriving on site to replace the cable and restore service.

Further updates will be provided as they are received from Openreach.

October 21, 2024 · 10:07 BST
Issue

We have been advised of an Openreach Major Service Outage affecting a handful of fibre customers. This may be due to a fibre cable being damaged in the current high winds.

We will continue to monitor this MSO and will provide further updates where possible.

October 20, 2024 · 23:41 BST

← Back