Service Outage

Major incident Brown Muir Mast Salterhill Relay East Mains Relay Miltonhill Relay Kellas Relay Sunnyside Relay Cul Mor Relay Ark Childcare Relay Newton Relay Mulben Mast Invercanna Relay Knockans Relay Garland Farm Relay Stoneyton Relay Maryhill Relay Coldhome Relay Aulton Farm Relay Balnellan Mast Lochliesk Farm Relay Duffus Mast Rothes Mast Rosehill Relay Collie Cottage Relay Glen of Rothes Relay Lochnabo Conasg Relay
2024-10-31 16:08 GMT · 3 days, 18 hours, 6 minutes

Updates

Resolved

Resolved.

November 4, 2024 · 10:14 GMT
Update

Engineers discovered damage to a power cable which caused a breaker to trip on-site. A temporary repair has been completed and we are making plans to complete a permanent repair next week.

We will continue to monitor to ensure there are no further issues.

October 31, 2024 · 21:56 GMT
Issue

We’re currently investigating an issue affecting our Brown Muir site, which impacts the Mulben, Duffus, and Rothes networks. Our engineers are on their way to determine the cause and restore service as soon as possible.

We’ll share further updates as we learn more. Thank you for your patience.

October 31, 2024 · 16:08 GMT

← Back