SSE Power Outage at Mulben Area

Minor incident Mulben Mast Invercanna Relay Knockans Relay Garland Farm Relay Stoneyton Relay Maryhill Relay Coldhome Relay Aulton Farm Relay
2025-01-27 12:32 GMT · 1 day, 22 hours, 22 minutes

Updates

Resolved

SSE power seems to be settled now in the area so all our systems are fully operational.

January 29, 2025 · 10:52 GMT
Issue

There is a SSE Power outage at Mulben that is affecting our service from from our Mulben network equipment. The power has been going on and off this morning. We have battery backup power at the Mulben exchange cabinet, but we now require an additional generator backup for our other cabinet further away. We should have temporary power installed in 30 minutes which will restore our service.

January 27, 2025 · 12:32 GMT

← Back