Mulben Area Outage

Major incident Mulben Mast Invercanna Relay Knockans Relay Garland Farm Relay Stoneyton Relay Maryhill Relay Coldhome Relay Aulton Farm Relay Balnellan Mast Lochliesk Farm Relay
2025-04-03 14:04 BST · 17 hours, 55 minutes

Updates

Resolved

Engineers successfully replaced the damaged section of fibre and the first services were restored by 6pm with all services back online by 6:30pm.

April 4, 2025 · 07:58 BST
Update

Engineers have confirmed that the cause of the outage is a fibre break. New fibre is on site and work is progressing to restore service.

April 3, 2025 · 15:39 BST
Issue

We are investigating a loss of service affecting our network in the Mulben area which is also having an impact on services in:

  • Coldhome
  • Balnellan
  • Lochliesk
  • Aberlour

Initial checks indicate this may be a power issue affecting the area but we will provide a further update once more information is available.

April 3, 2025 · 14:04 BST

← Back