Rosehill Relay outage

Minor incident Rothes Mast Rosehill Relay
2025-05-28 08:56 BST · 2 hours, 15 minutes, 1 second

Updates

Resolved

This issue has now been resolved. Thank you for your patience

May 28, 2025 · 11:10 BST
Issue

We are aware of an issue causing loss of service to customers on our Rosehill relay site in the Rothes Valley. Engineers are investigating the issue and we hope to have a resolution very soon.

May 28, 2025 · 08:56 BST

← Back