Ongoing Incident
Major incident
Brown Muir Mast
Salterhill Relay
East Mains Relay
Miltonhill Relay
Kellas Relay
Sunnyside Relay
Cul Mor Relay
Ark Childcare Relay
Newton Relay
Glen of Rothes Relay
Lochnabo
Conasg Relay
2025-06-15 21:35 BST
· 2 days, 12 hours, 53 minutes
Updates
Investigating
June 16, 2025 · 10:06 BST
An engineer is back on-site this morning to refuel the generator and resolve some issues that have appeared overnight. Current estimate from SSEN for restoration of power is 1pm today.
Issue
June 15, 2025 · 22:12 BST
We have confirmed that an SSE power outage is affecting our Brown Muir mast which has knocked out some equipment. An engineer is on route to the site with a generator to ensure that the site remains powered overnight and to restart the offline equipment.
← Back