SSE planned power outage

Major incident Mulben Mast Invercanna Relay Coldhome Relay Aulton Farm Relay Balnellan Mast Lochliesk Farm Relay
2025-06-24 21:16 BST · 22 hours, 13 minutes

Updates

Resolved

Power now restored

June 25, 2025 · 19:30 BST
Investigating

Power now restored.

June 25, 2025 · 19:28 BST
Issue

SSE have planned power outages tomorrow (25th June) around the maggieknockater area. We aren’t 100% sure of the outage area and how many transmission sites may be affected at present.

Battery backups on core sites will keep hardware running for a few hours, beyond that we apologise for any further power related outages.

Kind regards

WiFi Scotland

June 24, 2025 · 21:16 BST

← Back