Service issues
Minor incident
Linkwood Mast
Hallowood Road Relay
2025-07-14 20:23 BST
· 57 minutes
Updates
Resolved
July 14, 2025 · 21:21 BST
The replacement part has been fitted and all services have now been restored.
Issue
July 14, 2025 · 20:23 BST
We are aware of an issue affecting some customers on our Linkwood network. We have identified this as a failing power supply on one of the pieces of equipment at that site and an engineer will be onsite between 9pm and 10pm to replace the faulty part. This will necessitate a brief downtime for all Linkwood customers.
← Back