Loss of service

Major incident Elgin Core Birnie Relay Brown Muir Mast Salterhill Relay East Mains Relay Miltonhill Relay Kellas Relay Sunnyside Relay Cul Mor Relay Ark Childcare Relay Newton Relay Mulben Mast Invercanna Relay Knockans Relay Garland Farm Relay Stoneyton Relay Maryhill Relay Coldhome Relay Aulton Farm Relay Balnellan Mast Lochliesk Farm Relay Duffus Mast Wester Alves Mast Linkwood Mast Hallowood Road Relay Rothes Mast Rosehill Relay Collie Cottage Relay Tomintoul Network Cnoc Lochy Mast Farm Relay Distillery Relay Glen of Rothes Relay Lochnabo Conasg Relay Burghead Fibre Network Nether Dallachy Fibre Network Openreach Fibre
2025-07-20 18:57 BST · 57 minutes

Updates

Resolved

Engineers received information from a third-party supplier that the main outage was due to a failure in Edinburgh affecting ourselves and other customers of this supplier. We have requested a full Reason for Outage from our supplier to understand what caused the main outage.

Secondary to that was that the level of traffic across our network was high enough to overwhelm our backup links causing a complete outage. We already have a much higher capacity link on order to deal with this and have pressed the supplier of this circuit to expedite it to ensure we have the expected capacity and redundancy for our customers.

We apologise for any inconvenience.

July 20, 2025 · 19:49 BST
Issue

We are investigating a loss of service affecting all customers as of 18:55 today. Engineers are looking into the issue as a priority and we will provide an update as soon as we have more information.

July 20, 2025 · 18:57 BST

← Back