Loss of service

Minor incident Brown Muir Mast Salterhill Relay East Mains Relay Miltonhill Relay Kellas Relay Sunnyside Relay Cul Mor Relay Ark Childcare Relay Newton Relay Glen of Rothes Relay Lochnabo Conasg Relay
2025-12-06 19:40 GMT · 16 hours, 52 minutes

Updates

Resolved

The failed power supply has now been replaced and all services are coming back online.

December 7, 2025 · 12:31 GMT
Update

An engineer is now on route to site to replace the failed power supply. We will provide further updates in due course.

December 7, 2025 · 09:48 GMT
Issue

We are experiencing a loss of service to customers in the following areas:

  • Orton/Dipple
  • Gordon Castle
  • Gownie/Aberlour

We have traced the issue to a power supply failure at our Brown Muir mast which is affecting the feeds to those areas. An engineer will be heading to site tomorrow morning and we anticipate having service restored by 12noon.

December 6, 2025 · 19:40 GMT

← Back