Loss of service
Minor incident
Openreach Fibre
2025-12-15 13:12 GMT
· 19 hours, 1 minute
Updates
Resolved
December 16, 2025 · 08:14 GMT
Openreach have resolved the issue with the Exchange equipment and services have been restored.
Issue
December 15, 2025 · 13:12 GMT
We are aware of a fault affecting a number of customers on our Openreach fibre service. Openreach have advised us that there is an issue with the equipment in the Elgin Exchange that you are connected to and this is currently under investigation.
We are monitoring this and receiving updates from Openreach and will provide additional information when we have it available.
← Back
WiFi Scotland