Loss of service - Burghead/Alves areas

Major incident Burghead Fibre Network
2025-12-27 17:41 GMT · 2 hours, 39 minutes

Updates

Resolved

All services have now been restored.

December 27, 2025 · 20:19 GMT
Issue

We are aware of a loss of service for customers in the Alves and Burghead areas. This is related to a power outage affecting the Lossiemouth BT exchange which has not successfully switched to its emergency backup power.

An engineer is heading to site to put a temporary supply in place until mains power can be restored.

December 27, 2025 · 17:41 GMT

← Back