Connectivity Issues - Burghead

Minor incident Burghead Fibre Network
2026-02-13 13:48 GMT · 8 hours, 15 minutes

Updates

Resolved

Power has now been restored by SSEN.

February 13, 2026 · 22:03 GMT
Update

This issue has now been confirmed to be an SSEN power outage in the Roseisle area.

https://powertrack.ssen.co.uk/powertrack#SR6112

February 13, 2026 · 14:00 GMT
Issue

We are investigating a loss of connectivity affecting our Burghead fibre network. We will post a further update once we have determined the cause.

February 13, 2026 · 13:48 GMT

← Back