Loss of service - Glen of Rothes

Minor incident Brown Muir Mast Glen of Rothes Relay
2026-02-14 11:28 GMT · 6 hours, 8 minutes

Updates

Resolved

An engineer has visited the site and located a fault with the power cable to that mast. This has now been repaired and services restored.

February 14, 2026 · 17:35 GMT
Issue

We are currently investigating a loss of service with our Glen of Rothes relay. Engineers are looking into the cause and we will provide an update as soon as possible.

February 14, 2026 · 11:28 GMT

← Back