Loss of connectivity - Mulben Area
Minor incident
Mulben Mast
Invercanna Relay
Knockans Relay
Garland Farm Relay
Stoneyton Relay
Maryhill Relay
Coldhome Relay
Aulton Farm Relay
Balnellan Mast
Lochliesk Farm Relay
Rothes Mast
Rosehill Relay
Collie Cottage Relay
2026-04-01 13:20 BST
· 2 weeks, 3 days, 21 hours, 27 minutes
Updates
Update
April 1, 2026 · 14:06 BST
We have had confirmation now that the issue is due to an unplanned power outage in the Mulben/Orton areas. We will continue to monitor and will provide updates as we receive them from SSEN.
Issue
April 1, 2026 · 13:20 BST
We are currently investigating an issue causing a loss of connectivity for customers in the Mulben area. Engineers are looking into it and we will provide an update as soon as possible.
← Back
WiFi Scotland