Rothes Valley - Loss of Service

Minor incident Rothes Mast Rosehill Relay
2026-05-24 15:17 BST · 18 hours, 38 minutes

Updates

Resolved

Engineers discovered a fault with a power supply affecting the relay site equipment. A replacement was installed and service restored.

May 25, 2026 · 09:54 BST
Issue

We are aware of an issue affecting customers off our Rosehill relay in the Rothes Valley. An engineer is on-route to investigate the cause and we hope to have service restored soon.

May 24, 2026 · 15:17 BST

← Back