Burghead services - stability issues

Minor incident Burghead Fibre Network
2026-07-16 09:31 BST · 1 hour, 1 minute

Updates

Resolved

We have now resolved this issue and all services should be working properly again.

July 16, 2026 · 10:32 BST
Issue

We are currently investigating stability issues for customers on our Burghead fibre network. This seems to stem from a power outage this morning and we are working to identify the cause and resolve it as quickly as possible.

July 16, 2026 · 09:31 BST

← Back